Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 16, 2026 - 21:00 CEST
Scheduled
Am 16. Juni zwischen 21:00 und 24:00 Uhr führen wir notwendige Wartungsarbeiten an unserer E-Mail-Infrastruktur durch.
Was euch erwartet: Downtime: Die Postfächer werden innerhalb dieses Zeitfensters für etwa 1 bis 2 Stunden nicht erreichbar sein.
Auswirkungen: Während dieser Phase könnt ihr nicht auf eure Postfächer zugreifen und keine E-Mails senden oder empfangen. Eingehende E-Mails gehen dabei nicht verloren – sie werden von den absendenden Servern zwischengespeichert und automatisch zugestellt, sobald die Wartung abgeschlossen ist.
Wir versuchen, die Unterbrechung so kurz wie möglich zu halten, und geben euch hier Bescheid, sobald alles wieder wie gewohnt läuft. Vielen Dank für euer Verständnis!
---
On June 16th, between 9:00 PM and 12:00 AM (midnight) CEST, we will be performing essential maintenance on our mail infrastructure.
What to expect: Downtime: Inboxes will be temporarily unreachable for approximately 1 to 2 hours within this window.
Impact: During this time, you will not be able to access your mailboxes or send/receive emails. Any incoming emails sent to you during this window will be queued securely by the sending servers and delivered normally once the maintenance is complete.
We are aiming to keep the interruption as short as possible and will update you here as soon as the services are fully restored. Thank you for your patience and understanding!
Posted May 28, 2026 - 17:45 CEST
This scheduled maintenance affected: Mailservers (SMTP, IMAP, POP3, Webmail).